12bet - Bet365

12bet - Bet365.

You are not logged in.

#1 2020-09-13 16:42:08

From: Switzerland, Tavannes
Registered: 2020-09-13
Posts: 1

HP Touchpad with Plasma Mobile and openSUSE

Category: HP.

OpenSUSE Tumbleweed on an HP Zbook 15 G2 with Nvidia Quadro K2100M

I have reached the end of the road with this machine.
We have been together for about three years and before sending it off to the ether, I wanted to try out openSUSE  Tumbleweed  on it.
It was something of a question I have been asking myself since I was first assigned the piece of  hardware .
Windows 7 worked fine on it but how would it spin with the  Plasma desktop .
The  Opportunity .
Since I had received my ‘new’ computer and transferred  everything  over, I decided now was the time.
I felt it  important  to wipe the SSD on it anyway before shipping it out so trying out somethings seemed like a good idea.
In order to boot from the  USB drive , I had to change the boot order.
I went into the BIOS to access the boot option.
To go into the BIOS I pressed F10 on the POST Splash screen.
Using the  fantastic  openSUSE installer, I set up the machine very easily.
I realize, that at this point, this installer is like second nature to me so making it more “ user friendly ” would likely not be to my liking.
I did note that the default drive arrangement now is to have a single BTRFS  partition  with a Swap partition.
That isn’t my preference but I went with it.
After setting up all the bits, it took about 6 minutes to install the standard KDE Plasma desktop.
Fir reference, I am using snapshot 20200612 which includes Plasma version 5.19.
The initial boot took 32 seconds to get to the login screen.
Not sure if that is “fast” enough for most people but I was happy about that.
After logging in, it took another 7 seconds to a settled desktop… which is not to my dark-theme liking but easily remedied.
I have my color preference stored here but I really should put it out there as a downloadable theme… someday, perhaps.
Specifications (the ones that matter to me).
Using my favorite system info tool, neofetch, I installed that first.
sudo zypper install neofetch    and ran the thing to get the output of those little things that matter to me about the system        This basically told me what I wanted / needed to know    CPU: Intel i7-4810MQ, 8 thread at 3.80Ghz 4th Generation Core.
Screen: 1920×1080 matte finish screen.
GPU: Nvidia Quadro K2100M.
Memory: 32 GiB.
Storage: 477GiB SSD (no idea the brand, didn’t care).
This is by no means a new machine but it did do its job very effectively as a CAD machine.
Setup and Configuration.
Since the secondary monitor was to the left, I had to use the screen selection hotkey Fn+F4 to get to the onscreen switcher, arrow over and done.
Plasma is beautiful in the way it works like that.
Sicne the dark theme was added as previously described, I had to install the Multimedia Codecs from here.
It’s also good to check to make sure that my instructions are still valid.
They are.
The next thing to fix was this single-click nonsense.
Not a fan of this out of the gate but I understand that openSUSE likes to stay close to the upstream.
Not my preference but thankfully that is an easy fix by going to System Settings > General Behavior and changing the Click behavior to “Double-click to open files and folders.
The other thing I wanted to do was to set the window decoration to have the “Keep below” and “Keep above” buttons on it.
These are buttons I use quite often.
Mostly the “Keep Above” and to not have it makes my titlebar feel… inadequate.
Next was to install the Nvidia packages to take advantage of this GPU.
The easy way can be found here on the openSUSE Wiki.
I used YasST to do the installation as I was thought, why not.
There is more than one way to get to managing the Repositories.
I did it through the Software Management tool under Configuration > Repositories…    Next, I selected “Add” in the lower-left corner of the window then Community Repositories.
On the next screen, I added the nVidia Graphics Drivers.
When it begins the process of adding the repository, you are asked if you want to Import an Untrusted GnuPG Key.
I of course will trust this because, this is the openSUSE community.
After the import was complete, I searched and selected the nvidia-glG05* drivers which triggered the other required dependencies.
I selected the final Accept and the installation began.
Everything seemingly installed properly but I couldn’t use my secondary monitor after my reboot.
No idea why.
I event tried the older drivers but nothing.
I chalk that up to Nvidia being what Nvidia is… painful to deal with.
Maybe another distro would have recognized it better but I wasn’t interested as my time was incredibly limited with this machine.
I also downloaded the LeoCAD app Image because, why not do some fun CAD on this machine.
Since that worked out fantastically well, I thought I would do the other basic tests that I would need to do like visiting my favorite YouTube channels and made sure I could watch Netflix on Firefox.
It all went well and really, I wasn’t disappointed.
I did end up removing the proprietary Nvidia drivers and going with the open source option so I could use the secondary monitor.
Not a huge deal, a bit of a disappointment but at this stage I just wanted the secondary monitor.
The Good.
This machine feels super snappy.
Fast boot times, used very little memory when settled.
Seemingly things work fine, for regular user usage.
Though, this machine was specifically set up from HP as a CAD focused machine.
Having 32 GiB of RAM, and 8 threads is pretty great.
I didn’t get the opportunity to really test the hardware out as I would have liked but what little I did do, was pretty great.
The Touchpad is of a nice size and I like that there are buttons above and below the pad along with the Trackpoint between the G, H and B.
The Bad.
The keyboard on this machine is just miserable.
I am not sure what HP was thinking with this but the key-press is not consistent across the keyboard and they just don’t have a good feel to it.
I feel like I have to use unnecessary forceful key presses to get the keys to recognize.
The arrow keys are of a silly layout and I often stumble a bit on it.
Either hitting the up and down together or up and shift.
It wasn’t meant for my long gangling fingers.
The Ugly.
Nvidia didn’t play real well.
It worked but not like I would have preferred.
I wanted this to be a hugely bragging story about openSUSE and working well with Nvidia.
I am sure that had I dug into it a bit, I could have ironed it out but I was less than happy.
I have had other great success stories with Nvidia an openSUSE but this was not one of them.

… insert shrug emoji…        Outside of the Nvidia issue

which I may have eventually worked out if I had the time or the inclination, openSUSE Tumbleweed with the Plasma desktop was a nice experience.
At least, far nicer than the Windows 7 experience and now that I am thinking of it.
The graphics drivers on Windows were wonkey too.
I often had to reboot the machine to clear things up.
So, it is possible there may be something not quite right with the hardware.
It is also possible the keyboard may have been abused before I obtained it so that might account for the poor keyboard performance too.
If I had more time, I would have probably tried a few more distros on it.
Leap being one and Pop_!OS being the other.
Just to see if the Nvidia issue was a hardware thing.
Would I ever buy this machine for myself.
Lots of little things I don’t like about it, really.
I would call it an “almost” machine.
Everything about it is almost great but just happens to fall short in a lot of areas.
Download openSUSE TumbleweedCubicleNate.com openSUSE dark themeCubiclenate.com Multimedia Codecs terminal instructionsNvidia Drivers on the openSUSE WikiLeoCAD AppImage Download.
HP, , Nvidia, ,          4 Comments          17 June 202017 June 2020          6 Minutes                    HP TouchPad in 2018.1 Update.
Earlier this year, .

I repaired and updated my HP TouchPad with the latest firmware I could find

I have used it regularly since for numerous tasks and even tried to shoe horn it into other tasks to see if it would improve my workflow.
Was all that effort worth it.
Did I really need to take the time to fix and update a device long past it’s end of life date.
Here is what I can tell you about its usage.
Issues with the HP TouchPad.
It’s old and a bit slow, really but it has a fantastic screen, especially since it is 7 years old.
My expectations are not real high for its reliability but overall, it has surprised me.
Every so often, the thing will lock up and shut down but I haven’t been able to determine the cause, just random fluke.
Updating The HP TouchPad.
Unfortunately this process isn’t automatic but, it isn’t exactly difficult.

If you have done this much to your HP TouchPad

this shouldn’t be that much of an issue.
The latest firmware can be downloaded from here, which is the same source for firmware I used earlier this year.
To install the update, it required a reboot into the bootloader and install it from there.
There were no issues installing the update.
Unfortunately, this is an older version, LineageOS 11 which is still Android version 4.4.4.
It doesn’t appear to be a problem for the applications I am using.
There are several basic applications I use on a regular basis.
They work great and I use them reliably on a near daily basis.
Outside of the vanilla LineageOS applications, these are what I have installed to enhance the capabilities of this Tablet.
KDE Conenct.
For the media player controls over my main machine.
I use this often to start and stop media I use for helping in Home Education as well as a remote control over the living room computer so I can stop the Netflix.
Great for those Saturday mornings when the kids need to take a break from relaxing and knock out some chores.
Also, very conveniently, copying text to the clipboard on the computer or the tablet will allow me to share its contents back and forth.
So, I can copy a URL from the computer and paste it into the browser, sit and read the page on the couch as if I were curled up with a good book.
Only synchronizing the “Default Folder” as I don’t take pictures with this so the “Camera” folder which I don’t use on this common share.
The primary purpose is to quickly share something with the tablet, like a PDF or a screenshot from my Linux machine for convenient portability.
Ghost Commander.
My  new favorite file manager on Android.
It is reminiscent of the “Midnight Commander” file manager from times  Fennec F-Droid Web Browser.
This is a build of Firefox for Android that works very nicely Document Viewer.
A fine little application to view PDFs.
Probably the most used application on this tablet as I do reference a lot of PDFs LibreOffice Viewer.
For viewing “office documents” that are not PDFs.
I have used it for the open formats as well as the proprietary office formats of which we are all so familiar.
To so much for writing messages as reading messages.
I don’t really enjoy the touch screen keyboard as compared to the real thing but I’ll use it in a pinch.
All of these applications are available through F-Droid.
Updates are convenient enough but you will have to approve the permissions of the updates of each application individually.
Regular Usage.
I primarily use this tablet as a document viewing device: PDFs, Office Documents and images.
I also use it for casual web browsing, as a second screen for displaying a reference when I am away from my Cubicle.
I have a very convenient inductive charger for the tablet called the HP Touchstone Charger that allows me to just set the tablet in it, with the case and it will just charge.
No fiddling with the Micro USB cable to get the thing to charge.
It is an incredibly convenient accessory for this tablet.
I can’t help but wonder if there are other tablets so nicely designed.
It really is as if HP really thought through the design of this tablet very well.
This 7 year old tablet is still a fantastic piece of hardware.
I still think that if this machine were to be running a full fledged Linux Desktop, it would be much more useful and possibly run more efficiently.
I am a bit concerned that I cannot find a well functioning, more modern version of Android which is why I am increasingly more interested in a more open Linux OS for it.
For as long as this device lasts, I will continue to get squeeze every penny of use out of it.
When it does finally give up, I will miss it as it has been an incredibly useful tool that has made daily life just a bit easier.
Related Links.
HP TouchPad Tenderloin LineageOS Firmware https://f-droid.org/ HP TouchPad in 2018 HP Touchpad with Plasma Mobile and openSUSE — Fall Time Blathering.
Android, HP, Tablet, Upgrade         3 Comments          30 October 2018          4 Minutes                    HP Touchpad with Plasma Mobile and openSUSE — Fall Time Blathering.
After working with Plasma Mobile on the Nexus 5X and although it is not quite ready for prime time, it is nearly there.
It is so close, .

I can taste it and I am very ready to see Plasma Mobile as all I see on my mobile
I am also continually seeing interest on the aging HP Touchpad

It too is a fine piece of hardware that is still very capable and now, .

I can’t help but wonder how much work it would be to port Plasma Mobile to that hardware
I see that there has already been work with the Halium Project for the HP Touchpad

Unfortunately, my understanding at what goes on at the base hardware level is EXTREMELY limited.
Plasma Mobile Experience.
The look and feel of Plasma Mobile is pretty great.
Like all things Plasma, it is highly customizable.
What that means to me, I can make my Mobile experience exactly the way I want, not something dictated by a corporation as to how they intend for me to use my technology.
So then I thought, I know Plasma Mobile is still in early stages, many things are still being taken from Plasma Desktop but that really should only require some adjustments.
Over time, Plasma Mobile, much like the Desktop Counterpart could very well end up being the nicest, cleanest and yet most customiziable interface ever.
The HP Touchpad.
The Touchpad, by today’s standards is not spectacular, but it isn’t terrible either.
Its CPU is a dual core Scorpion clocked at 1200 MHz.
It has 1 GiB of RAM and either 16 or 32 GiB of storage.
It is certainly adequate for many tasks.
I can’t help but think how fantastic this Touchpad would be with proper Linux, access to the breadth of open source software.
The good news is, the possibility of having a working Plasma Mobile interface on the HP Touchpad may be closer to reality than not.
According to the Halium Project on GitHub, three have already been tests completed successfully.
This is, unfortunately far outside my skill sets so there isn’t much I can offer here but I am watching the project with great interest.
How Useful Could It Be?.
I know multimedia is the thing… streaming Netflix, watching YouTube and GPU intensive games is the common usage for tablets but that is not what I am interested in doing with it.
There are far more interesting and productive activities.
Using the Touchpad as my window into my digital recipe collection, reference technical documents, access to Kontact, the KDE Personal Information Manager, or at least parts of it for time and task management.
HP Touchpad with Plasma Mobile and openSUSE.
Then I did some more thinking.
I have only begun dabbling in the fantastic Open Build Service, but what if that system could be used to build an openSUSE Tumbleweed distribution specific to the HP Touchpad, tested by the openSUSE openQA and released in a similar rolling snapshot to the regular openSUSE Tumbleweed.
Even with a fraction of the stability, reliability of upgrades and the breadth of software, this would be a fantastic improvement as compared to what is available today.
It would be a gigantic library of goodness with many the most useful tools readily available.
Now What?.

Even though the HP Touchpad is far past its end of life

I continue to use it on a daily basis.
I am very interested in seeing the HP Touchpad get a more genuine Linux upgrade and would like to toy with it now but I have to personally determine, .

Do I want to take my HP Touchpad out of service

Would I even have the time test and experiment on it or do I continue to use it as it is.
It is very usable today and works mostly well but a project like this might give it enough life for perhaps several more years and be more useful than it is now.
For now, I will keep tabs on it but maybe in the very near future I will be able tip my toes in this arena.
Further Reading.
Halium for HP Touchpad Project on GitHub HP Touchpad Specifications Open Build Service Halium Project open QA openSUSE Tumbleweed Home HP Touchpad in 2018 Plasma Mobile installation on Nexus 5X KDE Kontact Personal Information Manager.
Android, , Hardware, HP, , , Mobile, Nonsense, , Tablet         1 Comment          7 October 2018                             openSUSE Tumbleweed on HP Pavilion 15.
I make no bones about the fact I am a Linux geek and try to make myself available to anyone with tech questions, but I typically will shy away from putting hands on to fix any Windows issues.
I just don’t have the time or patience to mess with it.
I was approached by a lady in my church with a brand new laptop telling me she wants me to install Linux on it.
We talked about what software she uses and the only application I don’t have a solution for (outside of using a VM) is iTunes.
Though, it looks like this may be a non-issue as she only uses it on her phone.
The computer is an HP Pavilion 15-cs0034cl with very nice specifications.
Much nicer than most of the hardware I own.
Intel Core i7-8550 @ 1.80GHz.
12 GiB of RAM.
Intel UHD Graphics 630 (Kabylake GT2).
Nvidia GeForce MX130.
Glossy 1920 x 1080 touch screen.
2x USB 3 Ports.
1 USB-C.
A REAL Ethernet port, Realtek RTL8111/8168/8411.
Intel Corporation Wireless 7265.
SD Card Reader.
1 TB Hard Drive (yes, spinning rust).
I prepared the installation USB Flash Drive by downloading and imaging the drive.
To start out, it is necessary to Access the BIOS: F10 Upon entering the BIOS, was a bit underwhelmed by the interface.
It has that early 2000s look to it; mostly blue and gray.
It also doesn’t have the breadth of options you would see on a Dell Latitude series of machines.
Even one from 10 plus years ago.
In order to access the boot options, arrow over to Boot System Configuration and press enter, then arrow down to Boot Options and press enter.
Ensure the following to get the system to boot from the USB Drive:  USB Boot is Enabled.
Secure Boot is Enabled.
UEFI Boot Order, moved USB Diskette on Key/USB Hard Drive to the top of the list.
Save and Exit, and began the installation process.
The install was without issue.
In order to make this work, I removed the largest partition and, formatted the EFI partition but left the Microsoft Reserved Partition and Diagnostic Partition intact.
Drive Layout.
260.00 MiB for /boot/efi.
12.00 GiB Swap  I left this at 12 GiB so that should the owner of this machine require suspending to disk, the space is available.
Many distros do not ship with this feature turned on but openSUSE does and it seemingly works fine on this machine.
25.00 GiB / (root).
0.86 TiB /home.
Nvidia Graphics.
To install the Nvidia drivers, taking advantage of the hybrid Intel / Nvidia technolgy, I used the openSUSE Wiki as a reference.
It is very nicely laid out, step-by-step.
The Nvidia drivers certainly are an exercise in frustration.
Maybe other distributions have the hybrid setups more dialed in but it is installed and usable.
Realistically, this machine is not ever going to have to use the Nvidia graphics but it’s nice to know it’s there.
Additional Software.
I installed my Basic Application List of the multimedia codecs and the Google Chrome browser.
I don’t have a lack of faith in Firefox but I know this particular user is more accustomed to Google Chrome.
I also transferred a simple script and .desktop file I put together to assist in keeping the system properly updated with little effort.
What I like.
This is a nice solid system that feels quality. I think I like the touch screen but at the same time just seems like a novel feature.
The system is fast, thin and light weight.
The keyboard isn’t bad and quite possibly one of the HP keyboards I have ever used.
The screen has a unique pivot point that tilts the laptop just a bit when it is opened.
Conveniently, this machine has an Intel Wireless NIC so there wasn’t any effort needed to get it operational.
Outside of the Nvidia GPU, there wasn’t any fiddling required on this machine to get everything working.
The screen is really sharp and crisp looking.
Based on the screen and keyboard alone, I could certainly use this as a daily driver.
What Don’t Like.
I would prefer to have an AMD GPU as it is easier to use for the hybrid function.
AMD has also open sourced their drivers so there is nothing that has to be done to get the needed performance out of your system.
I still like having an optical media drive, tho admittedly, I am not using one as often as I used to but I still prefer having one built in.
I also don’t like people touching my screen…  I wasn’t able to test the USB-C port as I don’t have anything that to plug into it.
Everything for this machine works right out of the gate.
I would recommend this machine for most people as it will do what most people need.
I only tested Tux Racer on this machine and it ran smashingly well, without any screen tearing or glitching.
I will be likely supporting this machine for quite a while but I don’t mind helping others get off of the proprietary software wagon.
I am a big believer in owning your own hardware, having something that is more secure on a platform you can trust.
Here is to hoping this conversion to Linux goes well.
openSUSE Wiki on NVIDIA Bumblebee Simple Tumbleweed Distribution Upgrade Script.
Hardware, HP, , , Nvidia,          6 Comments          2 September 2018          4 Minutes                    Six Steps to a Simple Samba Setup on openSUSE.
openSUSE is a very polished, commercial-feeling distribution of Linux.
The architects of the distribution have a much larger scope in mind of its usage than what I generally do.
One such area is Samba, SMB or often referred to as Windows Network File and Printer Sharing Protocol.
I only use this for one device on my network, my All-in-One, Printer-Scanner-Copier, The HP OfficeJet 8600.
It is a fine machine that does what I need it to do very well, but for scanning to a network folder, I must use Samba.
This process used to be much simpler, many years ago, before the discovery of security issues within Samba.
She short story of why there is the separation was some sort of vulnerability in the underlying system.
I am sure there is a fairly simple or straight forward way to make it all work but my intent was to successfully set up Samba with as little effort as possible.
I had a resource out on the web someplace that told me how to do this simply but I couldn’t find the bookmark nor was there a link in my digital notebook so I took a few sites, what I know about openSUSE and created an easy step-by-step guide for getting Samba file sharing up and running.
I have broken down the process into six easy to follow steps for a minimal setup.
I use this to quickly and easily set up and use Samba with openSUSE Linux.
Six Steps to a Simple Samba Setup on openSUSE.
Package Installation.
Minimum number of packages required to install the Samba Server Service Activation.
System Services that need to be activated and installed Firewall Configuration.
Allow access to the server through the firewall YaST Samba Setup.
Basic configuration using openSUSE’s system configuration tool.
Adding Samba Users.
Through the terminal, setting the username and password Testing it all out.
Making sure it actually works.
Samba is pretty easy to set up for a minimal usage.
For something more involved and complex, there are certainly better ways of accomplishing it.
Finally, if HP decided to put SFTP on their future All-in-One devices, this entire write up, to me, would be useless but until then, this is what is required.
Further Reading.
Six Steps to a Simple Samba Setup on openSUSE Samba on openSUSE Wiki Samba.org.
, HP, , , , Windows         Leave a comment          9 June 2018                             HP TouchPad in 2018.

I purchased two HP TouchPads a few years ago when they were fairly inexpensive

I wanted a larger tablet that wasn’t built cheaply.
They worked great for a while but started to act up.
I used them less and less until they just stopped working all together.
I put them on a shelf and forgot about the for quite a while.
A buddy of mine who is still seemingly a huge fan of the HP TouchPad diagnosed that one had a main board and battery failure while the other just a battery failure.
I put them back on the shelf and that is where they sat, once again.
He followed up with me wondering if I bought a battery yet (keeping me accountable) to which I did not.
He told me he had an extra battery and dropped it off along with the needed tools to disassemble and make the repair.
The guide I looked at made it seem like it would be easy to take the tablet apart, just work your way along the sides, as described and carefully separate the two halves.
What seemed to be missing from the article was that you have to shim the screen from the backing to keep it from clipping itself back shut again.
Once the tablet was apart, I disconnected the halves and started the process of removing more pieces until I could get the battery out.
I only ended up taking out 3 of the internal components.
Upon removing the USB board, I noticed that one of the wires for the little vibrator motor had somehow broken free from the board.
A fine explanation for why this unit didn’t have haptic feedback.
Thankfully, my soldiering skills were adequate enough to correct the issue.
There were only 4 screws retained the battery and it should be noted that once the screws have been removed, the battery will not come out easily as it is also adhered to the device.
Very careful and slow removal of the battery was warranted as I learned my lesson about removing a lithium polymer battery years ago on another project.
I didn’t want to rupture the sells and have a little fire or at least lots of heat and smoke.
Once I freed the battery from the case, I noticed that I could take a shortcut and remove the battery without disassembling all of the components as outlined in the guide.
I freed the battery from it’s compartment, set it aside, took the new battery and using a flat tipped screwdriver, was able to insert the connector of the new battery into the board and fasten it to the tablet body.  I effectively skipped the last 15 steps of the guide I used and reassembled it.
Success… but it didn’t turn on.
I figured that the thing needed to be charged so I let it charge overnight.
It still didn’t turn on and I felt obligated to let my buddy know that this TouchPad is dead and asked if he wanted the battery back.
Then, he asked if I did the hard reboot, hold power and volume down for 30 seconds.
I did just that and immediately it went to the ClockworkMod boot loader menu.
I selected the CyanogenMod image already installed on this TouchPad and I was very pleased to see that it was fully functional.
Since I wasn’t going to leave this with a 2 year old version of Android on it, I began my search for an updated ROM.
There are several options out there and some of the newer versions of Android seem to have Bluetooth or camera issues.
I didn’t want to have any hardware issues so I ended up going with this version here.
Everything works but it is an older version of Android with security patch updates.
Another requirement I made is that I wanted to ensure that there were no Google Services on this tablet as I didn’t want to weigh it down with all the data scraping and mining services.
All I want from this tablet is to do causal web browsing, reading ebook and PDF documents so there is no need to install the Gapps package.
I also wanted to see how useful a simple de-Googled tablet would be.
Since I did want to have access to applications on this device, I installed F-Droid.
F-Droid is similar to the Play Store, an available catalog of FOSS (Free and Open Source Software) Android applications.
Most of the applications I want to run are available there and anything else it is possible for me to sideload or install using Yalp.
The applications I installed:.
KDE Connect.
Fennec F-Droid, a Mozilla based web browser.
Barcode Scanner.
Book Reader.
Yalp, allows you to download apps directly from Google Play Store as apk files.
Installed Using Yalp:.
ASTRO File Manager.
Modifications to improve my usage experience.
I turned off the KDE Connect Telegram Notification.
Not because I don’t like Telegram but because I don’t want multiple notifications on my Desktop Linux machine for the same message.
To do so, withing the KDE Connect Application on the paired device Menu > Plugin settings > Notification sync configure button, scrolled down to Telegram and uncheck it.
Next, I made the KDE Connect Keyboard an input option by going into System Settings > Language & Input and checked KDE Connect Remote Keyboard  I set up a folder on the Tablet called Sync and using Syncthing have it tied to two of my openSUSE desktop Linux machines.
It is an easy and efficient drag and drop method of putting files on the tablet instead of using KDE Connect.
I figure, more options are better than fewer options for sharing data.
Using Dolphin in KDE Plasma to drag and drop files right on the HP TouchPad file system is such a fantastic feature.
This, combined with having a folder that I can use to sync between all my systems and a shared clipboard gives me the truly practical form of desktop/mobile convergence.
What I like.
The size of this tablet is perfect for how I intend on using it.
I can check things, look up things, and use it for accessing references in either PDF, ebook or my favorite resource, the openSUSE Wiki.
To copy and paste from the tablet is made super easy, thanks to KDE Conenct.
Copy on the tablet, paste on the Desktop.
This tablet has such a nice weight and feel about and the protective folio-style case is great.
I have all the functions and features I need to do what I set out with this 2011 built tablet.
Sure, it is old and well past a tablet end of life but it is fast, very snappy and responsive.
What I Don’t Like.
I have an outdated version of Android but with the security patches back-ported though, I do like the dark look of the older Android UI, so lets call this point a wash.
The downside is, it doesn’t allow for certain newer KDE Connect features as noted here by one of the developers.
I also may have done something to disconnect the internal speakers as I don’t hear sound unless I plug into the headphone jack or Bluetooth speaker.
I am not really using this for multimedia and the workaround is satisfactory.
I am not a fan of the rear facing only camera on the tablet.
It also distorts the image during the “live view” but the picture itself has the proper aspect ratio.
Unless if I want too take some awkward selfies, I don’t see this as a terrible issue.

I am very glad to have a working HP TouchPad once again

Is it indeed limited but I am not using it like a brand new tablet, I am using it closer to how a tablet was used 7 years ago.
I am also not using this tablet like I would a proper computer as that would require a keyboard and mouse and once I have added those items, I may as well use a laptop.
This fantastic little device does just what I want it to do, superbly.
Using KDE Connect and Syncthing, I can have the proper mobile/desktop convergence with my openSUSE Linux desktops in a highly practical manner anywhere I go, without the need for a third party service.
I am not sure what I will do with the other tablet now.
This one is just so great, I might have to get the other one working just to keep in my cubicle.
Would I recommend this tablet to someone else.
For most people, probably not, unless they like to noodle around with technology.  Was it worth taking the time to fix it.
Also, probably not but the satisfaction for me out of making this older yet perfectly usable hardware functional once again makes it more than worth the time and effort.
Further Reading, useful links and such.
I Fix It Guide for the HP TouchPad Tenderloin Android ROM I have installed on my HP Touchpad openSUSE Wiki KDE Connect Developer Nico’s Blog Post KDE Connect Community Site.
Android, , Hardware, HP, , , , Repair, Tablet, Upgrade         4 Comments          21 April 201830 October 2018          6 Minutes                                                                                                                Post to              Cancel                                               Send to Email Address          Your Name       Your Email Address.



Board footer

Powered by FluxBB